PointOnPlane Class

PointOnPlane Class

Define a ReferencePoint relative to a planar reference.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBPointElementReference
    Autodesk.Revit.DBPointOnPlane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class PointOnPlane : PointElementReference
Public Class PointOnPlane
	Inherits PointElementReference
public ref class PointOnPlane : public PointElementReference
type PointOnPlane = 
    class
        inherit PointElementReference
    end

The PointOnPlane type exposes the following members.

Properties
 NameDescription
Public propertyOffsetSigned offset from the plane.
Public propertyPositionThe coordinates of the point (or its projection) on the plane.
Public propertyXVecThe X-coordinate vector of the point, in the plane's coordinate system.
Top
Methods
 NameDescription
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetPlaneReferenceThe geometric plane reference.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodStatic memberIsValidPlaneReferenceCheck whether a geometry reference corresponds to a referenceable plane.
Public methodStatic memberNewPointOnPlaneConstruct a PointOnPlane given a reference and a location in space.
Public methodSetPlaneReferenceChange the geometric plane reference.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
A ReferencePoint on a plane has its X and Y basis vectors parallel to the plane, but is free to rotate around its Z basis vector. It can lie on the plane or have an offset.
See Also