GroupSet Class

GroupSet Class

An set that contains groups.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBGroupSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class GroupSet : APIObject, IEnumerable
Public Class GroupSet
	Inherits APIObject
	Implements IEnumerable
public ref class GroupSet : public APIObject, 
	IEnumerable
type GroupSet = 
    class
        inherit APIObject
        interface IEnumerable
    end

The GroupSet type exposes the following members.

Constructors
 NameDescription
Public methodGroupSetInitializes a new instance of the GroupSet class
Top
Properties
 NameDescription
Public propertyIsEmptyTest to see if the set is empty.
Public propertyIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertySizeReturns the number of groups that are in the set.
Top
Methods
 NameDescription
Public methodClearRemoves every group from the set, rendering it empty.
Public methodContainsTests for the existence of a group within the set.
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodEraseRemoves a specified group from the set.
Public methodForwardIteratorRetrieve a forward moving iterator to the set.
Public methodGetEnumeratorRetrieve a forward moving iterator to the set.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodInsertInsert the specified group into the set.
Public methodReverseIteratorRetrieve a backward moving iterator to the set.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also