OverrideGraphicSettings.SetSurfaceForegroundPatternColor Method

OverrideGraphicSettingsSetSurfaceForegroundPatternColor Method

Sets the override color of the surface foreground pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public OverrideGraphicSettings SetSurfaceForegroundPatternColor(
	Color color
)
Public Function SetSurfaceForegroundPatternColor ( 
	color As Color
) As OverrideGraphicSettings
public:
OverrideGraphicSettings^ SetSurfaceForegroundPatternColor(
	Color^ color
)
member SetSurfaceForegroundPatternColor : 
        color : Color -> OverrideGraphicSettings 

Parameters

color  Color
Value of the surface foreground color for the override. InvalidColorValue means no override is set.

Return Value

OverrideGraphicSettings
Reference to the changed object.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also