Revit 2025.3 API
Wall |
Creates a new wall foundation within the project.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static WallFoundation Create( Document document, ElementId typeId, ElementId wallId )
Public Shared Function Create ( document As Document, typeId As ElementId, wallId As ElementId ) As WallFoundation
public: static WallFoundation^ Create( Document^ document, ElementId^ typeId, ElementId^ wallId )
static member Create : document : Document * typeId : ElementId * wallId : ElementId -> WallFoundation
Parameters
- document Document
- The document.
- typeId ElementId
- The id of the wall foundation type of the newly created wall foundation.
- wallId ElementId
- The id of the host wall of the newly created wall foundation.
Return Value
WallFoundationIf successful, returns the newly created wall foundation, otherwise.

Exception | Condition |
---|---|
ArgumentException | typeId is not a valid WallFoundationType id. -or- wallId does not refer to a valid wall. |
ArgumentNullException | A non-optional argument was null |
See Also