ShapeImporter Class

ShapeImporter Class

A utility class that supports conversion of geometry stored in an external format into a Revit geometry objects.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBShapeImporter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ShapeImporter : IDisposable
Public Class ShapeImporter
	Implements IDisposable
public ref class ShapeImporter : IDisposable
type ShapeImporter = 
    class
        interface IDisposable
    end

The ShapeImporter type exposes the following members.

Constructors
 NameDescription
Public methodShapeImporter Default constructor. Initializes an instance of ShapeImporter that will automatically recognize the file format from its extension (ShapeImporterSourceFormat.Auto).
Top
Properties
 NameDescription
Public propertyDefaultLengthUnit The length unit to be used if not specified when the input is a unitless SAT file.
Public propertyInputFormat The format of the incoming data.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodConvert Converts the geometry stored in the external format into a collection of Revit geometry objects.
Public methodDisposeReleases all resources used by the ShapeImporter
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodStatic memberIsServiceAvailable Checks whether the data conversion service is available.
Public methodSetDefaultLengthUnit Sets the length unit to be used when the input is a unitless SAT file.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
See ShapeImporterSourceFormat for the list of supported formats.
See Also