ShapeImporter.DefaultLengthUnit Property

ShapeImporterDefaultLengthUnit Property

The length unit to be used if not specified when the input is a unitless SAT file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ImportUnit DefaultLengthUnit { get; }
Public ReadOnly Property DefaultLengthUnit As ImportUnit
	Get
public:
property ImportUnit DefaultLengthUnit {
	ImportUnit get ();
}
member DefaultLengthUnit : ImportUnit with get

Property Value

ImportUnit
Remarks
If the input is a unitless SAT file then this length unit will be used as a backup.
See Also