SpacingRule Class

SpacingRule Class

A rule for specifying a set of equidistant, parallel gridlines within a region.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBSpacingRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class SpacingRule : APIObject
Public Class SpacingRule
	Inherits APIObject
public ref class SpacingRule : public APIObject
type SpacingRule = 
    class
        inherit APIObject
    end

The SpacingRule type exposes the following members.

Properties
 NameDescription
Public propertyBeltMeasurement On a curved surface, BeltMeasurement specifies where the grid's distances are measured.
Public propertyDistanceThe exact distance between layout lines.
Public propertyGridlinesRotationAn additional rotation to be applied to this set of grid lines.
Public propertyHasBeltMeasurement True if the gridlines are not parallel due to surface curvature, and the BeltMeasurement property therefore applies.
Public propertyIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyJustificationThe justification of the lines within the region.
Public propertyLayoutA choice of several gridline layout rules.
Public propertyNumberThe exact number of lines in the region.
Public propertyOffsetAn additional offset applied to the first gridline.
Top
Methods
 NameDescription
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodSetLayoutFixedDistanceSet the Layout property to FixedDistance.
Public methodSetLayoutFixedNumberSet the Layout property to FixedNumber.
Public methodSetLayoutMaximumSpacingSet the Layout property to MaximumSpacing.
Public methodSetLayoutMinimumSpacingSet the Layout property to MinimumSpacing.
Public methodSetLayoutNoneSet the Layout property to None.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also