ElementType.IsValidDefaultFamilyType Method

ElementTypeIsValidDefaultFamilyType Method

Identifies if this type is a valid default family type for the given family category id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool IsValidDefaultFamilyType(
	ElementId familyCategoryId
)
Public Function IsValidDefaultFamilyType ( 
	familyCategoryId As ElementId
) As Boolean
public:
bool IsValidDefaultFamilyType(
	ElementId^ familyCategoryId
)
member IsValidDefaultFamilyType : 
        familyCategoryId : ElementId -> bool 

Parameters

familyCategoryId  ElementId
The family category id.

Return Value

Boolean
True if this type is a valid default family type for the given family category id.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also