SketchedStairsCurveData Class

SketchedStairsCurveData Class

Sketched run/landing curves overrides with height and slope
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBSketchedStairsCurveData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class SketchedStairsCurveData : IDisposable
Public Class SketchedStairsCurveData
	Implements IDisposable
public ref class SketchedStairsCurveData : IDisposable
type SketchedStairsCurveData = 
    class
        interface IDisposable
    end

The SketchedStairsCurveData type exposes the following members.

Constructors
 NameDescription
Public methodSketchedStairsCurveData Construct a SketchedStairsCurveData defined by a curve associated with its height and slope type.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the SketchedStairsCurveData
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetCurve Get a copy of the curve that is formed along this boundary.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also