BaseImportOptions.ReferencePoint Property

BaseImportOptionsReferencePoint Property

The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public XYZ ReferencePoint { get; set; }
Public Property ReferencePoint As XYZ
	Get
	Set
public:
property XYZ^ ReferencePoint {
	XYZ^ get ();
	void set (XYZ^ value);
}
member ReferencePoint : XYZ with get, set

Property Value

XYZ
Exceptions
ExceptionCondition
ArgumentNullException When setting this property: A non-optional argument was null
See Also