FabricationService Class

FabricationService Class

This object contains information about a fabrication service.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBFabricationService

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FabricationService : IDisposable
Public Class FabricationService
	Implements IDisposable
public ref class FabricationService : IDisposable
type FabricationService = 
    class
        interface IDisposable
    end

The FabricationService type exposes the following members.

Properties
 NameDescription
Public propertyAbbreviation The short name of service.
Public propertyFabricationSystemName The fabrication system name of the service.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyName The name of the service.
Public propertyPaletteCount The number of palettes in the service.
Public propertyServiceId The service identifier of the service.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the FabricationService
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetButton Gets the service button for a given palette index and button index from the service.
Public methodGetButtonCount Gets the number of buttons for a given palette in the service.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetPaletteName Gets the name of a palette based on palette index.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIsCompatibleWith Check whether the service is broadly interchangable with another one without affecting part geometry. The services must have the same fabrication system template and specification.
Public methodIsPaletteExcluded Get whether a service palette is excluded from being used by the Route and Fill, Design to Fabrication, or Multi Point Routing commands. The default configuration values may be overridden by SetServicePaletteExclusions.
Public methodIsValidButtonIndex Validates the button index.
Public methodIsValidPaletteIndex Validates the palette index.
Public methodOverrideServiceButtonExclusion Overrides the default service button exclusions, used by Route and Fill, Design to Fabrication, or Multi Point Routing for the current user and session only.
Public methodResetServiceExclusionOverrides Resets the overridden service palette and button exclusions back to default, as defined by the configuration.
Public methodSetServicePaletteExclusions 
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
A fabrication service defines what fabrication service buttons that can be used. Fabrication services are part of the fabrication configuration.
See Also