Revit 2025.3 API
Compound |
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool IsValid( Document doc, out IDictionary<int, CompoundStructureError> errMap, out IDictionary<int, int> twoLayerErrorsMap )
Public Function IsValid ( doc As Document, <OutAttribute> ByRef errMap As IDictionary(Of Integer, CompoundStructureError), <OutAttribute> ByRef twoLayerErrorsMap As IDictionary(Of Integer, Integer) ) As Boolean
public: bool IsValid( Document^ doc, [OutAttribute] IDictionary<int, CompoundStructureError>^% errMap, [OutAttribute] IDictionary<int, int>^% twoLayerErrorsMap )
member IsValid : doc : Document * errMap : IDictionary<int, CompoundStructureError> byref * twoLayerErrorsMap : IDictionary<int, int> byref -> bool
Parameters
- doc Document
- errMap IDictionaryInt32, CompoundStructureError
- twoLayerErrorsMap IDictionaryInt32, Int32
Return Value
BooleanSee Also