CurveLoopsProfile Class

CurveLoopsProfile Class

Represents a curve loop based profile for sweep or swept blend elements.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBSweepProfile
      Autodesk.Revit.DBCurveLoopsProfile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class CurveLoopsProfile : SweepProfile
Public Class CurveLoopsProfile
	Inherits SweepProfile
public ref class CurveLoopsProfile : public SweepProfile
type CurveLoopsProfile = 
    class
        inherit SweepProfile
    end

The CurveLoopsProfile type exposes the following members.

Properties
 NameDescription
Public propertyIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyProfileReturns the curve loops of the profile.
Top
Methods
 NameDescription
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
Use objects of this type in methods as NewSweep() and NewSweptBlend() in FamilyItemFactory to create the profile.
See Also