Revit 2025.3 API
Document |
Indicates if an element can be deleted.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static bool CanDeleteElement( Document document, ElementId elementId )
Public Shared Function CanDeleteElement ( document As Document, elementId As ElementId ) As Boolean
public: static bool CanDeleteElement( Document^ document, ElementId^ elementId )
static member CanDeleteElement : document : Document * elementId : ElementId -> bool
Parameters
Return Value
BooleanTrue if the element can be deleted, false otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
See Also