DimensionSegmentArray Class

DimensionSegmentArray Class

An array that can contain any number of DimensionSegment objects.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBDimensionSegmentArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class DimensionSegmentArray : APIObject, 
	IEnumerable
Public Class DimensionSegmentArray
	Inherits APIObject
	Implements IEnumerable
public ref class DimensionSegmentArray : public APIObject, 
	IEnumerable
type DimensionSegmentArray = 
    class
        inherit APIObject
        interface IEnumerable
    end

The DimensionSegmentArray type exposes the following members.

Constructors
 NameDescription
Public methodDimensionSegmentArrayInitializes a new instance of the DimensionSegmentArray class
Top
Properties
 NameDescription
Public propertyIsEmptyTest to see if the array is empty.
Public propertyIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyItemGets or sets an item at a specified index within the array.
Public propertySizeReturns the number of objects that are in the array.
Top
Methods
 NameDescription
Public methodAppendAdd the item to the end of the array.
Public methodClearRemoves every item from the array, rendering it empty.
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodForwardIteratorRetrieve a forward moving iterator to the array.
Public methodGetEnumeratorRetrieve a forward moving iterator to the array.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodInsertInsert the specified item into the array.
Public methodReverseIteratorRetrieve a backward moving iterator to the array.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also