FabricWireItem Class

FabricWireItem Class

Provides implementation for FabricWires stored in a Custom Fabric Sheet
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.StructureFabricWireItem

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FabricWireItem : IDisposable
Public Class FabricWireItem
	Implements IDisposable
public ref class FabricWireItem : IDisposable
type FabricWireItem = 
    class
        interface IDisposable
    end

The FabricWireItem type exposes the following members.

Properties
 NameDescription
Public propertyDistance Distance to the next fabric wire item Can be 0 to be used with offset along wire.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyOffsetAlongWire Offset along wire direction Wire distance should be 0 if we want to be along the same wire
Public propertyWireLength Wire length for this wire item
Public propertyWireType The wire type of this wire item
Top
Methods
 NameDescription
Public methodStatic memberCreate Creates a new instance of a single Fabric wire.
Public methodDisposeReleases all resources used by the FabricWireItem
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also