Toposolid.CanBeExcavatedBy Method

ToposolidCanBeExcavatedBy Method

Checks if the given element can be used to excavate the toposolid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool CanBeExcavatedBy(
	ElementId elementId
)
Public Function CanBeExcavatedBy ( 
	elementId As ElementId
) As Boolean
public:
bool CanBeExcavatedBy(
	ElementId^ elementId
)
member CanBeExcavatedBy : 
        elementId : ElementId -> bool 

Parameters

elementId  ElementId
Id of the element

Return Value

Boolean
True if the element can be used to excavate the toposolid.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also