Revit 2025.3 API
Plan |
Set the level for a View Depth plane
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void SetLevelId( PlanViewPlane planViewPlane, ElementId id )
Public Sub SetLevelId ( planViewPlane As PlanViewPlane, id As ElementId )
public: void SetLevelId( PlanViewPlane planViewPlane, ElementId^ id )
member SetLevelId : planViewPlane : PlanViewPlane * id : ElementId -> unit
Parameters
- planViewPlane PlanViewPlane
- The View Depth plane
- id ElementId
- Id of the level

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
See Also