ViewScheduleExportOptions Class

ViewScheduleExportOptions Class

The export options used to export schedule views.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBViewScheduleExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ViewScheduleExportOptions : IDisposable
Public Class ViewScheduleExportOptions
	Implements IDisposable
public ref class ViewScheduleExportOptions : IDisposable
type ViewScheduleExportOptions = 
    class
        interface IDisposable
    end

The ViewScheduleExportOptions type exposes the following members.

Constructors
 NameDescription
Public methodViewScheduleExportOptions Constructs a new instance of the ViewScheduleExportOptions class
Public methodViewScheduleExportOptions(ViewScheduleExportOptions) Constructs a new copy of the input ViewScheduleExportOptions object.
Top
Properties
 NameDescription
Public propertyColumnHeaders How to export column headers. Default is MultipleRows.
Public propertyFieldDelimiter How to delimit fields. Default is Tab.
Public propertyHeadersFootersBlanks Whether to export group headers, footers, and blank lines. Default is true.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyTextQualifier How to qualify text fields. Default is DoubleQuote.
Public propertyTitle Whether or not to export the schedule title. Default is true.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ViewScheduleExportOptions
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also