GroupLoadOptions Class

GroupLoadOptions Class

A class containing options for loading a group from a file.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBGroupLoadOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class GroupLoadOptions : IDisposable
Public Class GroupLoadOptions
	Implements IDisposable
public ref class GroupLoadOptions : IDisposable
type GroupLoadOptions = 
    class
        interface IDisposable
    end

The GroupLoadOptions type exposes the following members.

Constructors
 NameDescription
Public methodGroupLoadOptions Creates a new instance of a GroupLoadOptions object.
Top
Properties
 NameDescription
Public propertyIncludeAttachedDetails True if attached detail groups should be included, false otherwise. The default value is .
Public propertyIncludeGrids True if grids should be brought in from the input file, false otherwise. The default value is .
Public propertyIncludeLevels True if levels should be brought in from the input file, false otherwise. The default value is .
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyReplaceDuplicatedGroups If there are groups with the same names in source and destination documents set this property to to replace existing groups, otherwise the operation will be canceled. The default value is .
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the GroupLoadOptions
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetDuplicateTypeNamesHandler Returns current duplicate type names handler or if none is set.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodSetDuplicateTypeNamesHandler Sets a custom duplicate type names handler. If this value is not set, the default handler is used. By default, Revit displays a modal dialog with options to either copy new types only, or cancel the operation.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also