SpatialElementGeometryCalculator(Document) Constructor

SpatialElementGeometryCalculator(Document) Constructor

Constructs a new calculator with default options for the geometry of spatial elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public SpatialElementGeometryCalculator(
	Document aDoc
)
Public Sub New ( 
	aDoc As Document
)
public:
SpatialElementGeometryCalculator(
	Document^ aDoc
)
new : 
        aDoc : Document -> SpatialElementGeometryCalculator

Parameters

aDoc  Document
The document that contains the spatial elements.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also