RebarShape.SetEndTreatmentTypeId Method

RebarShapeSetEndTreatmentTypeId Method

Sets the EndTreatmentType id at the specified rebar shape end.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void SetEndTreatmentTypeId(
	ElementId endTreatmentId,
	int iEnd
)
Public Sub SetEndTreatmentTypeId ( 
	endTreatmentId As ElementId,
	iEnd As Integer
)
public:
void SetEndTreatmentTypeId(
	ElementId^ endTreatmentId, 
	int iEnd
)
member SetEndTreatmentTypeId : 
        endTreatmentId : ElementId * 
        iEnd : int -> unit 

Parameters

endTreatmentId  ElementId
The id of an EndTreatmentType element, or invalidElementId if the rebar shape should have no end treatment at the specified end.
iEnd  Int32
0 for the start end treatment, 1 for the end end treatment.
Exceptions
ExceptionCondition
ArgumentException iEnd not a valid shape end -or- the parameter endTreatmentId is not an EndTreatmentType element.
ArgumentNullException A non-optional argument was null
See Also