DirectShapeType.AddReferencePoint(XYZ) Method

DirectShapeTypeAddReferencePoint(XYZ) Method

Adds a reference point to the DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void AddReferencePoint(
	XYZ refPoint
)
Public Sub AddReferencePoint ( 
	refPoint As XYZ
)
public:
void AddReferencePoint(
	XYZ^ refPoint
)
member AddReferencePoint : 
        refPoint : XYZ -> unit 

Parameters

refPoint  XYZ
The coordinates of the new reference point.
Exceptions
ExceptionCondition
ArgumentException The input point lies outside of Revit design limits.
ArgumentNullException A non-optional argument was null
See Also