Revit 2025.3 API
DocumentExport(String, String, STLExport |
Exports a view specified in the export options to the STL format.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool Export( string folder, string name, STLExportOptions options )
Public Function Export ( folder As String, name As String, options As STLExportOptions ) As Boolean
public: bool Export( String^ folder, String^ name, STLExportOptions^ options )
member Export : folder : string * name : string * options : STLExportOptions -> bool
Parameters
- folder String
- Output folder into which the file will be exported. The folder must exist.
- name String
- Indicates the name of the STL file to export. If it doesn't end with ".stl", this extension will be added automatically. The name cannot contain any of the following characters: \/:*?"<>|. Empty name is not acceptable.
- options STLExportOptions
- Various options applicable to the STL format.
Return Value
BooleanTrue if successful, otherwise False.

Exception | Condition |
---|---|
ArgumentException | NullOrEmpty -or- Contains invalid characters. -or- The provided options do not specify a printable 3D view. |
ArgumentNullException | A non-optional argument was null |
ForbiddenForDynamicUpdateException | This method may not be called during dynamic update. |
InvalidOperationException | Export is temporarily disabled. -or- Exporting is not allowed in the current application mode. |
InvalidPathArgumentException | The folder does not exist. |
OptionalFunctionalityNotAvailableException | The ShapeExporter functionality is not available in the installed Revit, or the Material Library is missing. |
See Also