ReferenceWithContext Class

ReferenceWithContext Class

An object including a reference to a geometric object and related context, as instance transform etc.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBReferenceWithContext

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ReferenceWithContext : IDisposable
Public Class ReferenceWithContext
	Implements IDisposable
public ref class ReferenceWithContext : IDisposable
type ReferenceWithContext = 
    class
        interface IDisposable
    end

The ReferenceWithContext type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyProximity The proximity value to the ray's origin when the reference is returned by FindReferencesWithContextByDirection(XYZ, XYZ, View3D) or ReferenceIntersector.Find(XYZ, XYZ).
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ReferenceWithContext
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetInstanceTransform Gets the transform of the instance.
Public methodGetReference Gets the reference of the geometric object.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
The ReferenceWithContext is used as the returned value from the method [!:Autodesk::Revit::DB::Document::FindReferencesWithContextByDirection], ReferenceIntersector.Find(XYZ, XYZ), or ReferenceIntersector.FindNearest(XYZ, XYZ). It includes a reference intersecting a line extended in a certain direction from an origin point and the context of the geometric object, as the transform and proximity.
See Also