SolidCurveIntersectionOptions Class

SolidCurveIntersectionOptions Class

This class contains the options used to calculate the intersection between a solid and a curve.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBSolidCurveIntersectionOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class SolidCurveIntersectionOptions : IDisposable
Public Class SolidCurveIntersectionOptions
	Implements IDisposable
public ref class SolidCurveIntersectionOptions : IDisposable
type SolidCurveIntersectionOptions = 
    class
        interface IDisposable
    end

The SolidCurveIntersectionOptions type exposes the following members.

Constructors
 NameDescription
Public methodSolidCurveIntersectionOptions Constructs a new SolidCurveIntersectionMode with default settings.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyResultType The type of results expected by the calculation. The default is CurveSegmentsInside.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the SolidCurveIntersectionOptions
Top
See Also