BuiltInFailures.LevelFailures Class

BuiltInFailuresLevelFailures Class

Failures about Level.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresLevelFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static class LevelFailures
Public NotInheritable Class LevelFailures
public ref class LevelFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type LevelFailures = class end

The BuiltInFailuresLevelFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberNoLevelsLeft There are no levels or plan views remaining in the project.
Public propertyStatic memberNoLevelsLeftReloading As a result of Reloading Latest, there are no Levels left. Create a new Level, and then Reload Latest again.
Public propertyStatic memberStoryAboveDeleted The level set as the Story Above for these levels is being deleted. This change will cause these levels to revert to the default Story Above.
Public propertyStatic memberStoryAboveMoved The level set as the Story Above for these levels has moved below these levels. This change will cause these levels to revert to the default Story Above.
Public propertyStatic memberStoryAboveNonStoryLevel The level set as the Story Above for these levels is no longer a story level. This change will cause these levels to revert to the default Story Above.
Top
See Also