Revit 2025.3 API
Appearance |
Gets the rendering asset for the appearance asset element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public Asset GetRenderingAsset()
Public Function GetRenderingAsset As Asset
public: Asset^ GetRenderingAsset()
member GetRenderingAsset : unit -> Asset
Return Value
AssetThe rendering asset held by this appearance asset element.

The retrieved Asset may be empty if it is loaded from material library without any modification.
In this case, you can use Application.GetAssets(AssetType.Appearance) to load all preset appearance assets, and retrieve the asset by its name.
See Also