Revit 2026 API
Value |
Stores values at one domain point.
Each value corresponds to a "measurement" for which this value was calculated.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
The ValueAtPoint type exposes the following members.

Name | Description | |
---|---|---|
![]() | ValueAtPoint(IListDouble) | Initializes a new instance of the ValueAtPoint class |
![]() | ValueAtPoint(ValueAtPoint) | Creates a copy of the given ValueAtPoint instance. |

Name | Description | |
---|---|---|
![]() | IsValidObject |
Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ValueAtPointBase) |

Name | Description | |
---|---|---|
![]() | ClearAllFlags |
Sets flags for all measurements to ValueAtPointFlags::None.
(Inherited from ValueAtPointBase) |
![]() | ClearFlagsAt |
Sets flags for the given measurement to ValueAtPointFlags::None.
(Inherited from ValueAtPointBase) |
![]() | Dispose | (Inherited from ValueAtPointBase) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object) |
![]() | GetFlags |
Returns flags for the given measurement.
(Inherited from ValueAtPointBase) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object) |
![]() | SetFlags(IListInt32) | (Inherited from ValueAtPointBase) |
![]() | SetFlags(Int32) |
Sets the flags associated to all measurements to the same value.
(Inherited from ValueAtPointBase) |
![]() | SetFlags(Int32, Int32) |
Sets the flags associated to a given measurement.
(Inherited from ValueAtPointBase) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object) |
See Also