Revit 2026 API
Stairs |
Specifies whether the .NET object represents a valid Revit entity.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean Get
public: property bool IsValidObject { bool get (); }
member IsValidObject : bool with get
Return Value
BooleanTrue if the API object holds a valid Revit native object, false otherwise.

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone,
a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also