StairsComponentConnection Class

StairsComponentConnection Class

Represents information about a connection among stairs components(run to landing).
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.ArchitectureStairsComponentConnection

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class StairsComponentConnection : IDisposable
Public Class StairsComponentConnection
	Implements IDisposable
public ref class StairsComponentConnection : IDisposable
type StairsComponentConnection = 
    class
        interface IDisposable
    end

The StairsComponentConnection type exposes the following members.

Properties
 NameDescription
Public propertyConnectionType The connection type of the connected stairs component.
Public propertyElementId The element Id of connected stairs component in the stairs connection.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyPeerConnectionType The connection type of the peer connected stairs component.
Public propertyPeerElementId The element Id of peer connected stairs component in the stairs connection.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the StairsComponentConnection
Top
See Also