BoundingBoxIntersectsFilter(Outline, Double) Constructor

BoundingBoxIntersectsFilter(Outline, Double) Constructor

Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public BoundingBoxIntersectsFilter(
	Outline outline,
	double tolerance
)
Public Sub New ( 
	outline As Outline,
	tolerance As Double
)
public:
BoundingBoxIntersectsFilter(
	Outline^ outline, 
	double tolerance
)
new : 
        outline : Outline * 
        tolerance : float -> BoundingBoxIntersectsFilter

Parameters

outline  Outline
The Outline used to find elements with a bounding box that intersect it.
tolerance  Double
The tolerance value to use instead of zero. See the tolerance property for details.
Exceptions
ExceptionCondition
ArgumentException outline is an empty Outline. -or- The given value for tolerance is not finite -or- The given value for tolerance is not a number
ArgumentNullException A non-optional argument was null
See Also