BoundingBoxIntersectsFilter Class

BoundingBoxIntersectsFilter Class

A filter used to match elements with a bounding box that intersects the given Outline.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElementFilter
    Autodesk.Revit.DBElementQuickFilter
      Autodesk.Revit.DBBoundingBoxIntersectsFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class BoundingBoxIntersectsFilter : ElementQuickFilter
Public Class BoundingBoxIntersectsFilter
	Inherits ElementQuickFilter
public ref class BoundingBoxIntersectsFilter : public ElementQuickFilter
type BoundingBoxIntersectsFilter = 
    class
        inherit ElementQuickFilter
    end

The BoundingBoxIntersectsFilter type exposes the following members.

Constructors
 NameDescription
Public methodBoundingBoxIntersectsFilter(Outline) Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.
Public methodBoundingBoxIntersectsFilter(Outline, Boolean) Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline, with the option to invert the filter and match all elements with a bounding box that are not intersecting the given Outline.
Public methodBoundingBoxIntersectsFilter(Outline, Double) Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.
Public methodBoundingBoxIntersectsFilter(Outline, Double, Boolean) Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline, with the option to invert the filter and match all elements with a bounding box that are not intersecting the given Outline.
Top
Properties
 NameDescription
Public propertyInverted True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted.
(Inherited from ElementFilter)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ElementFilter)
Public propertyTolerance Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.
Top
Methods
 NameDescription
Public methodDispose
(Inherited from ElementFilter)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetBoundingBox Gets the outline being used for this filter.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodPassesFilter(Element) Applies the filter to a given element.
(Inherited from ElementFilter)
Public methodPassesFilter(Document, ElementId) Applies the filter to a given element.
(Inherited from ElementFilter)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
This filter excludes all objects derived from View and objects derived from ElementType. This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
See Also