MEPCalculationServerInfo Class

MEPCalculationServerInfo Class

a struct to hold the information about a MEP calucation servers
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBMEPCalculationServerInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class MEPCalculationServerInfo : IDisposable
Public Class MEPCalculationServerInfo
	Implements IDisposable
public ref class MEPCalculationServerInfo : IDisposable
type MEPCalculationServerInfo = 
    class
        interface IDisposable
    end

The MEPCalculationServerInfo type exposes the following members.

Constructors
 NameDescription
Public methodMEPCalculationServerInfo Constructs a new MEPCalculationServerInfo with default settings.
Public methodMEPCalculationServerInfo(IExternalServer) Create a new MEPCalculationServerInfo by an external server.
Public methodMEPCalculationServerInfo(MEPCalculationServerInfo) Constructs a new copy of the input MEPCalculationServerInfo object.
Top
Properties
 NameDescription
Public propertyDescription The Description of the server.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyStatic memberPipeUseDefinitionOnTypeGUID The guid value ("3BF616F9-6B98-4A21-80FF-DA1120C8F6D6") of Use Definition On Type. It is not a server id, but a guid to tell if the loss method is "Use Definition On Type" or not. If the loss method is "Use Definition On Type", we use the loss method of the family type to calculate.
Public propertyServerId The Id of the server.
Public propertyServerName The Name of the server.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the MEPCalculationServerInfo
Public methodStatic memberGetMEPCalculationServerInfo Gets a MEPCalculationServerInfo by family instance.
Top
See Also