Revit 2026 API
Building |
Specific options for the method analyzing the building elements for the building envelope.

SystemObject
Autodesk.Revit.DB.AnalysisBuildingEnvelopeAnalyzerOptions
Autodesk.Revit.DB.AnalysisBuildingEnvelopeAnalyzerOptions
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
The BuildingEnvelopeAnalyzerOptions type exposes the following members.

Name | Description | |
---|---|---|
![]() | BuildingEnvelopeAnalyzerOptions | Constructs a new instance of BuildingEnvelopeAnalyzerOptions, using default values. |

Name | Description | |
---|---|---|
![]() | AnalyzeEnclosedSpaceVolumes | Whether or not to analyze interior connected regions inside the building forming enclosed space volumes. |
![]() | GridCellSize | The cell size for the uniform cubical grid used when analyzing the building envelope. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | OptimizeGridCellSize | Whether or not to use the exact value for the cell size or let the analyzer optimize the cell size based on the specified grid size |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the BuildingEnvelopeAnalyzerOptions |

The analyze method uses a combination of ray-casting and flood-fill
algorithms in order to find the building elements that are
exposed to the outside of the building.
The analyze method can also look for the bounding building elements for
enclosed space volumes inside the building.
See Also