Location Class

Location Class

Provides location functionality for all elements.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBLocation
      Autodesk.Revit.DBLocationCurve
      Autodesk.Revit.DBLocationPoint

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class Location : APIObject
Public Class Location
	Inherits APIObject
public ref class Location : public APIObject
type Location = 
    class
        inherit APIObject
    end

The Location type exposes the following members.

Properties
 NameDescription
Top
Methods
 NameDescription
Public methodMoveMove the element within the project by a specified vector.
Public methodRotateRotate the element within the project by a specified angle around a given axis.
Top
Remarks
The location object provides the ability to translate and rotate elements. More detailed location information and control can be found by using the derivatives of this object, such as LocationPoint or LocationCurve.
See Also