Location.Rotate Method

LocationRotate Method

Rotate the element within the project by a specified angle around a given axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public bool Rotate(
	Line axis,
	double angle
)
Public Function Rotate ( 
	axis As Line,
	angle As Double
) As Boolean
public:
bool Rotate(
	Line^ axis, 
	double angle
)
member Rotate : 
        axis : Line * 
        angle : float -> bool 

Parameters

axis  Line
An unbounded line that represents the axis of rotation.
angle  Double
The angle, in radians, by which the element is to be rotated around the specified axis.

Return Value

Boolean
If the element is rotate successfully then the method returns True, otherwise False.
Remarks
The rotate method is used to rotate an element within the project. Other elements may also be rotated when this element is rotated because they are dependent upon the element being rotated. An unbounded line for the axis can be created by using the Application.Create object and its methods.
See Also