Revit 2026 API
Field |
Contains values corresponding to domain points.
Each domain point may have an array of values, each corresponding to a separate "measurement" for which this value was calculated.

SystemObject
Autodesk.Revit.DB.AnalysisFieldValues
Autodesk.Revit.DB.AnalysisFieldValues
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
The FieldValues type exposes the following members.

Name | Description | |
---|---|---|
![]() | FieldValues(FieldValues) | Creates a copy of the given FieldValues instance. |
![]() | FieldValues(IListValueAtPoint) | Initializes a new instance of the FieldValues class |
![]() | FieldValues(IListVectorAtPoint) | Initializes a new instance of the FieldValues class |
![]() | FieldValues(IListValueAtPoint, XYZ) | Initializes a new instance of the FieldValues class |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the FieldValues |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object) |
See Also