FamilySymbol.SetThermalProperties Method

FamilySymbolSetThermalProperties Method

Sets the thermal properties for the given FamilySymbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void SetThermalProperties(
	FamilyThermalProperties thermalProperties
)
Public Sub SetThermalProperties ( 
	thermalProperties As FamilyThermalProperties
)
public:
void SetThermalProperties(
	FamilyThermalProperties^ thermalProperties
)
member SetThermalProperties : 
        thermalProperties : FamilyThermalProperties -> unit 

Parameters

thermalProperties  FamilyThermalProperties
The new thermal properties. If , this unsets custom thermal properties for this FamilySymbol.
Exceptions
ExceptionCondition
ArgumentException The thermal properties are not valid for assignment.
InvalidOperationException This FamilySymbol does not contain thermal properties.
See Also