Revit 2026 API
Invalid |
The exception that is thrown when a method call is invalid for the object's current state.

SystemObject
SystemException
Autodesk.Revit.ExceptionsApplicationException
Autodesk.Revit.ExceptionsInvalidOperationException
More
SystemException
Autodesk.Revit.ExceptionsApplicationException
Autodesk.Revit.ExceptionsInvalidOperationException
More
Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[SerializableAttribute] public class InvalidOperationException : ApplicationException
<SerializableAttribute> Public Class InvalidOperationException Inherits ApplicationException
[SerializableAttribute] public ref class InvalidOperationException : public ApplicationException
[<SerializableAttribute>] type InvalidOperationException = class inherit ApplicationException end
The InvalidOperationException type exposes the following members.

Name | Description | |
---|---|---|
![]() | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception) |
![]() | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException) |
![]() | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception) |
![]() | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception) |
![]() | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception) |
![]() | Message | Gets a message that describes the current exception. (Inherited from Exception) |
![]() | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception) |
![]() | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception) |
![]() | TargetSite | Gets the method that throws the current exception. (Inherited from Exception) |

Name | Description | |
---|---|---|
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object) |
![]() | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object) |
![]() | GetObjectData | Retrieves data needed to serialize the target object. (Overrides ApplicationExceptionGetObjectData(SerializationInfo, StreamingContext)) |
![]() | GetType | Gets the runtime type of the current instance. (Inherited from Exception) |
![]() | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception) |
See Also
Reference

SystemObject
SystemException
Autodesk.Revit.ExceptionsApplicationException
Autodesk.Revit.ExceptionsInvalidOperationException
Autodesk.Revit.ExceptionsAutoJoinFailedException
Autodesk.Revit.ExceptionsCannotOpenBothCentralAndLocalException
Autodesk.Revit.ExceptionsDefaultValueException
Autodesk.Revit.ExceptionsDisabledDisciplineException
Autodesk.Revit.ExceptionsFamilyContextException
Autodesk.Revit.ExceptionsForbiddenForDynamicUpdateException
Autodesk.Revit.ExceptionsInapplicableDataException
Autodesk.Revit.ExceptionsInsufficientResourcesException
Autodesk.Revit.ExceptionsInvalidObjectException
Autodesk.Revit.ExceptionsModificationForbiddenException
Autodesk.Revit.ExceptionsModificationOutsideTransactionException
Autodesk.Revit.ExceptionsNotTransmittedModelException
Autodesk.Revit.ExceptionsObjectAccessException
Autodesk.Revit.ExceptionsOptionalFunctionalityNotAvailableException
Autodesk.Revit.ExceptionsRegenerationFailedException
Autodesk.Revit.ExceptionsSchemaException
Autodesk.Revit.ExceptionsTransientElementCreationException
Autodesk.Revit.ExceptionsTransmittedModelException
Autodesk.Revit.ExceptionsWrongUserException
SystemException
Autodesk.Revit.ExceptionsApplicationException
Autodesk.Revit.ExceptionsInvalidOperationException
Autodesk.Revit.ExceptionsAutoJoinFailedException
Autodesk.Revit.ExceptionsCannotOpenBothCentralAndLocalException
Autodesk.Revit.ExceptionsDefaultValueException
Autodesk.Revit.ExceptionsDisabledDisciplineException
Autodesk.Revit.ExceptionsFamilyContextException
Autodesk.Revit.ExceptionsForbiddenForDynamicUpdateException
Autodesk.Revit.ExceptionsInapplicableDataException
Autodesk.Revit.ExceptionsInsufficientResourcesException
Autodesk.Revit.ExceptionsInvalidObjectException
Autodesk.Revit.ExceptionsModificationForbiddenException
Autodesk.Revit.ExceptionsModificationOutsideTransactionException
Autodesk.Revit.ExceptionsNotTransmittedModelException
Autodesk.Revit.ExceptionsObjectAccessException
Autodesk.Revit.ExceptionsOptionalFunctionalityNotAvailableException
Autodesk.Revit.ExceptionsRegenerationFailedException
Autodesk.Revit.ExceptionsSchemaException
Autodesk.Revit.ExceptionsTransientElementCreationException
Autodesk.Revit.ExceptionsTransmittedModelException
Autodesk.Revit.ExceptionsWrongUserException