Revit 2026 API
Element |
Duplicates an existing element type and assigns it a new name.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public ElementType Duplicate( string name )
Public Function Duplicate ( name As String ) As ElementType
public: ElementType^ Duplicate( String^ name )
member Duplicate : name : string -> ElementType
Parameters
- name String
- The new name of the element type.
Return Value
ElementTypeThe duplicated element type.

Exception | Condition |
---|---|
ArgumentException | name is an empty string. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- The element type name was empty, contained invalid characters, or was invalid for the specific element type. -or- The name is already in use for this element type. |
ArgumentNullException | A non-optional argument was null |
InternalException | Duplicate element type could not be obtained. |
InvalidOperationException | The ElementType cannot be copied. |
See Also