Fascia.AddSegment Method

FasciaAddSegment Method

Add segments to the fascia.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public override void AddSegment(
	Reference targetRef
)
Public Overrides Sub AddSegment ( 
	targetRef As Reference
)
public:
virtual void AddSegment(
	Reference^ targetRef
) override
abstract AddSegment : 
        targetRef : Reference -> unit 
override AddSegment : 
        targetRef : Reference -> unit 

Parameters

targetRef  Reference
Segment's reference on which want to be added.
Exceptions
ExceptionCondition
ArgumentNullException This exception will be thrown in following cases: 1. Input targetRef is . 2. Input targetRef is not but contains nothing.
InvalidOperationException This exception will be thrown in following cases: 1. Input targetRef has already been added into the fascia. 2. Internal code fails to create the segment object. 3. Regeneration fails.
ArgumentOutOfRangeException This exception will be thrown if the reference is suitable for creating a fascia as required. The reference allowed is : 1. Model Line 2. Roof's horizontal edges 3. Soffit's horizontal edges 4. Other fascia's horizontal edges
See Also