Revit 2026 API
Hosted |
Set segment's start point or end point parameter.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public bool SetEndPointParameter( Reference targetRef, int endIdx, double param )
Public Function SetEndPointParameter ( targetRef As Reference, endIdx As Integer, param As Double ) As Boolean
public: bool SetEndPointParameter( Reference^ targetRef, int endIdx, double param )
member SetEndPointParameter : targetRef : Reference * endIdx : int * param : float -> bool
Parameters
- targetRef Reference
- Segment's reference whose parameter want to be set.
- endIdx Int32
- Start point (=0) or end point (=1).
- param Double
- Value of parameter.
Return Value
Booleantrue if operation success.

Exception | Condition |
---|---|
InvalidOperationException | Thrown when regeneration fails. |
See Also