ObjectTable.ModifyAttributes Method (RhinoObject, ObjectAttributes, Boolean)

ObjectTableModifyAttributes Method (RhinoObject, ObjectAttributes, Boolean)

Modifies an object's attributes. Cannot be used to change object id.

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public bool ModifyAttributes(
	RhinoObject obj,
	ObjectAttributes newAttributes,
	bool quiet
)
Public Function ModifyAttributes ( 
	obj As RhinoObject,
	newAttributes As ObjectAttributes,
	quiet As Boolean
) As Boolean

Parameters

obj
Type: Rhino.DocObjectsRhinoObject
object to modify.
newAttributes
Type: Rhino.DocObjectsObjectAttributes
new attributes.
quiet
Type: SystemBoolean
if true, then warning message boxes are disabled.

Return Value

Type: Boolean
true if successful.
Version Information

Rhino for Mac

Supported in: 5.4

Rhino for Windows

Supported in: 6.8
See Also