RhinoObject Class |
RhinoObjects should only ever be creatable by the RhinoDoc.

Namespace: Rhino.DocObjects
Assembly: RhinoCommon (in RhinoCommon.dll)

The RhinoObject type exposes the following members.

Name | Description | |
---|---|---|
![]() | Attributes |
Gets or sets the object attributes.
|
![]() | ComponentStatus |
Gets or sets the component status of the model component.
(Inherited from ModelComponent.) |
![]() | ComponentType |
Returns ModelGeometry.
(Overrides ModelComponentComponentType.) |
![]() | DeletedName |
Gets the name of a component that is deleted.
(Inherited from ModelComponent.) |
![]() | Disposed |
Indicates if this object has been disposed or the
document it originally belonged to has been disposed.
(Inherited from CommonObject.) |
![]() | Document |
Gets the document that owns this object.
|
![]() | Geometry |
Gets the underlying geometry for this object.
All rhino objects are composed of geometry and attributes. |
![]() | GripsOn | Gets or sets the activation state of object default editing grips. |
![]() | GripsSelected |
true if grips are turned on and at least one is selected.
|
![]() | GroupCount | Number of groups object belongs to. |
![]() | HasDynamicTransform |
True if the object has a dynamic transformation
|
![]() | HasId |
Returns a value indicating whether the component has an ID.
(Inherited from ModelComponent.) |
![]() | HasIndex |
Returns a value indicating whether the component has an Index.
(Inherited from ModelComponent.) |
![]() | HasName |
Returns a value indicating whether the component has a Name.
(Inherited from ModelComponent.) |
![]() | HasSubobjectMaterials |
Will be true if the object contains sub object meshes with materials
that are different than the top level object.
|
![]() | HasUserData |
Gets true if this class has any custom information attached to it through UserData.
(Inherited from CommonObject.) |
![]() | Id |
Every object has a Guid (globally unique identifier, also known as UUID, or universally
unique identifier). The default value is Guid.Empty.
When an object is added to a model, the value is checked. If the value is Guid.Empty, a new Guid is created. If the value is not null but it is already used by another object in the model, a new Guid is created. If the value is not Guid.Empty and it is not used by another object in the model, then that value persists. When an object is updated, by a move for example, the value of ObjectId persists. This value is the same as the one returned by this.Attributes.ObjectId. |
![]() | IdIsLocked |
Returns a value indicating whether the component ID is already locked.
(Inherited from ModelComponent.) |
![]() | Index |
Gets or sets the model component index attribute.
(Inherited from ModelComponent.) |
![]() | IndexIsLocked |
Returns a value indicating whether the component Index is already locked.
(Inherited from ModelComponent.) |
![]() | IsComponentStatusLocked |
The component status itself can be locked. This returns an indication.
(Inherited from ModelComponent.) |
![]() | IsDeletable |
Some objects cannot be deleted, like grips on lights and annotation objects.
|
![]() | IsDeleted |
true if the object is deleted. Deleted objects are kept by the document
for undo purposes. Call RhinoDoc.UndeleteObject to undelete an object.
|
![]() | IsDocumentControlled |
If true this object may not be modified. Any properties or functions that attempt
to modify this object when it is set to "IsReadOnly" will throw a NotSupportedException.
(Inherited from CommonObject.) |
![]() | IsHidden |
An object must be in one of three modes: normal, locked or hidden.
If an object is in normal mode, then the object's layer controls visibility
and selectability. If an object is locked, then the object's layer controls
visibility by the object cannot be selected. If the object is hidden, it is
not visible and it cannot be selected.
|
![]() | IsInstanceDefinitionGeometry |
true if the object is used as part of an instance definition.
|
![]() | IsLocked |
An object must be in one of three modes: normal, locked or hidden.
If an object is in normal mode, then the object's layer controls visibility
and selectability. If an object is locked, then the object's layer controls
visibility by the object cannot be selected. If the object is hidden, it is
not visible and it cannot be selected.
|
![]() | IsNormal |
An object must be in one of three modes: normal, locked or hidden.
If an object is in normal mode, then the object's layer controls visibility
and selectability. If an object is locked, then the object's layer controls
visibility by the object cannot be selected. If the object is hidden, it is
not visible and it cannot be selected.
|
![]() | IsReference |
Gets a value indicating if an object is a reference object. An object from a work session
reference model is a reference object and cannot be modified. An object is
a reference object if, and only if, it is on a reference layer.
|
![]() | IsSystemComponent |
True if this model component is a system constant.
(Inherited from ModelComponent.)An incomplete list of system constant model components is below:
|
![]() | IsValid |
Tests an object to see if its data members are correctly initialized.
In Rhino for Windows 6.8, this member is inherited from CommonObjectIsValid. |
![]() | Name |
Rhino objects have optional text names. More than one object in
a model can have the same name and some objects may have no name.
|
![]() | NameIsLocked |
Returns a value indicating whether the component Name is already locked.
(Inherited from ModelComponent.) |
![]() ![]() | NextRuntimeSerialNumber |
Gets the runtime serial number that will be assigned to
the next Rhino Object that is created.
|
![]() | ObjectType |
Gets the Rhino-based object type.
|
![]() | RenderMaterial |
Gets the render material associated with this object or null if there
is none. This does not pay attention to the material source and will
not check parent objects or layers for a RenderMaterial.
|
![]() | RuntimeSerialNumber |
Gets the objects runtime serial number.
|
![]() | SubobjectMaterialComponents | |
![]() | UserData |
List of custom information that is attached to this class.
(Inherited from CommonObject.) |
![]() | UserDictionary |
Dictionary of custom information attached to this class. The dictionary is actually user
data provided as an easy to use sharable set of information.
(Inherited from CommonObject.) |
![]() | Visible | Gets the object visibility. |
![]() | WorksessionReferenceSerialNumber |
Worksession reference model id.
0: layer is not in a reference model.
1: layer is in an unidentified worksession reference model.
>1000: Serial number of the worksession reference model.
The reference model serial number is a runtime value.
It is not saved in files and it is generally different the
next time a file is read.
|

Name | Description | |
---|---|---|
![]() | ClearId |
Resets the HasId property of the model component to false, if possible.
(Inherited from ModelComponent.) |
![]() | ClearIndex |
Resets the HasIndex property of the model component to false, if possible.
(Inherited from ModelComponent.) |
![]() | ClearName |
Resets the HasName property of the model component to false, if possible.
(Inherited from ModelComponent.) |
![]() ![]() | CommitChanges |
Moves changes made to this RhinoObject into the RhinoDoc.
|
![]() | ConstructConstObject |
Assigns a parent object and a subobject index to this.
(Inherited from CommonObject.) |
![]() | CreateMeshes |
Create meshes used to render and analyze surface and polysrf objects.
|
![]() | DataCRC |
Increments the Cyclic Redundancy Check value by this instance.
(Inherited from ModelComponent.) |
![]() | Description |
Get a brief description of a object, including it's attributes and geometry.
|
![]() | Dispose |
Actively reclaims unmanaged resources that this instance uses.
(Inherited from CommonObject.) |
![]() | Dispose(Boolean) |
For derived class implementers.
(Inherited from CommonObject.)This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method. You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true. Also, you must call the base virtual method within your overriding method. |
![]() ![]() | DuplicateGeometry |
Constructs a deep (full) copy of the geometry.
|
![]() | EnableCustomGrips | Turns on/off the object's editing grips. |
![]() | EnableVisualAnalysisMode |
Used to turn analysis modes on and off.
|
![]() | EnsurePrivateCopy |
If you want to keep a copy of this class around by holding onto it in a variable after a command
completes, call EnsurePrivateCopy to make sure that this class is not tied to the document. You can
call this function as many times as you want.
(Inherited from CommonObject.) |
![]() | Equals | (Inherited from Object.) |
![]() | Finalize | (Inherited from Object.) |
![]() | Finalize |
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Inherited from CommonObject.) |
![]() ![]() | FromRuntimeSerialNumber | Get a Rhino object for a unique runtime serial number |
![]() | GetActiveVisualAnalysisModes |
Gets a list of currently enabled analysis modes for this object.
|
![]() | GetCustomRenderMeshParameter |
Query the object for the value of a given named custom render mesh parameter.
|
![]() | GetDynamicTransform |
While an object is being dynamically tranformed (dragged, rotated, ...),
the current transformation can be retrieved and used for creating
dynamic display.
|
![]() ![]() | GetFillSurfaces(RhinoObject, ClippingPlaneObject) |
Return list of fill surfaces if any for object and clipping plane.
|
![]() ![]() | GetFillSurfaces(RhinoObject, IEnumerableClippingPlaneObject) |
Return list of fill surfaces if any for object and clipping plane. Fills are trimmed by
clipping planes that did not generate them.
|
![]() ![]() | GetFillSurfaces(RhinoObject, IEnumerableClippingPlaneObject, Boolean) |
Return list of fill surfaces if any for object and clipping plane.
|
![]() | GetGrips |
Returns grips for this object If grips are enabled. If grips are not
enabled, returns null.
|
![]() | GetGroupList |
Allocates an array of group indices of length GroupCount.
If GroupCount is 0, then this method returns null.
|
![]() | GetHashCode | (Inherited from Object.) |
![]() | GetHighlightedSubObjects |
Gets a list of all highlighted subobjects.
|
![]() | GetMaterial(Boolean) |
Gets material that this object uses based on it's attributes and the document
that the object is associated with. In the rare case that a document is not
associated with this object, null will be returned.
|
![]() | GetMaterial(ComponentIndex) |
Get the Material associated with the sub object
identified by componentIndex if the component index is
set to ComponentIndex.Unset
then the top level material is returned.
|
![]() | GetMaterial(ComponentIndex, Guid) |
Get the Material associated with the sub object
identified by componentIndex if the component index is
set to ComponentIndex.Unset
then the top level material is returned.
|
![]() | GetMaterial(ComponentIndex, Guid, ObjectAttributes) |
Get the Material associated with the sub object
identified by componentIndex if the component index is
set to ComponentIndex.Unset then the top level material
is returned.
|
![]() | GetMeshes |
Get existing meshes used to render and analyze surface and polysrf objects.
|
![]() | GetObjectData |
Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.
(Inherited from CommonObject.) |
![]() | GetRenderMaterial(Boolean) |
Gets the RenderMaterial that this object uses based on it's attributes
and the document that the object is associated with. If there is no
RenderMaterial associated with this object then null is returned. If
null is returned you should call GetMaterial to get the material used
to render this object.
|
![]() | GetRenderMaterial(ComponentIndex) |
Gets the RenderMaterial associated with this object if there is one. If
there is no RenderMaterial associated with this object then null is
returned. If null is returned you should call GetMaterial to get the
material used to render this object.
|
![]() | GetRenderMaterial(ComponentIndex, Guid) |
Gets the RenderMaterial associated with this object if there is one. If
there is no RenderMaterial associated with this object then null is
returned. If null is returned you should call GetMaterial to get the
material used to render this object.
|
![]() | GetRenderMaterial(ComponentIndex, Guid, ObjectAttributes) |
Gets the RenderMaterial associated with this object if there is one. If
there is no RenderMaterial associated with this object then null is
returned. If null is returned you should call GetMaterial to get the
material used to render this object.
|
![]() ![]() | GetRenderMeshes |
Gets the render meshes of some objects.
|
![]() | GetRenderMeshParameters |
Meshing parameters that this object uses for generating render meshes. If the
object's attributes do not have custom meshing parameters, then the document's
meshing parameters are used.
|
![]() | GetRenderPrimitiveList(ViewportInfo, DisplayPipelineAttributes) |
Build custom render mesh(es) for this object.
|
![]() | GetRenderPrimitiveList(ViewportInfo, Boolean) | Obsolete.
Build custom render mesh(es) for this object.
|
![]() | GetSelectedSubObjects | Get a list of all selected sub-objects. |
![]() | GetSubObjects |
Gets an array of sub-objects.
|
![]() | GetTextureChannels |
Get a list of the texture mapping channel Id's associated with object.
|
![]() | GetTextureMapping(Int32) | |
![]() | GetTextureMapping(Int32, Transform) |
Get objects texture mapping
|
![]() | GetType | (Inherited from Object.) |
![]() | HasTextureMapping |
Returns true if this object has a texture mapping form any source (pluginId)
|
![]() | Highlight |
Modifies the highlighting of the object.
|
![]() | HighlightSubObject |
Highlights a subobject.
|
![]() | InVisualAnalysisMode |
Reports if any visual analysis mode is currently active for an object.
|
![]() | InVisualAnalysisMode(VisualAnalysisMode) |
Reports if a visual analysis mode is currently active for an object.
|
![]() | IsActiveInViewport |
Determine if this object is active in a particular viewport.
|
![]() | IsHighlighted | Check highlight state. |
![]() | IsMeshable |
Returns true if the object is capable of having a mesh of the specified type
|
![]() | IsSelectable | Reports if an object can be selected. |
![]() | IsSelectable(Boolean, Boolean, Boolean, Boolean) | Reports if an object can be selected. |
![]() | IsSelected | Check selection state. |
![]() | IsSubObjectHighlighted |
Determines if a subobject is highlighted.
|
![]() | IsSubObjectSelectable | Reports if a subobject can be selected. |
![]() | IsSubObjectSelected | Check sub-object selection state. |
![]() | IsValidWithLog |
Determines if an object is valid. Also provides a report on errors if this
object happens not to be valid.
(Inherited from CommonObject.) |
![]() | LockId |
Locks the component Id property.
(Inherited from ModelComponent.) |
![]() | LockIndex |
Locks the component Index property.
(Inherited from ModelComponent.) |
![]() | LockName |
Locks the component Name property.
(Inherited from ModelComponent.) |
![]() | MemberwiseClone | (Inherited from Object.) |
![]() | MemoryEstimate |
Computes an estimate of the number of bytes that this object is using in memory.
Note that this is a runtime memory estimate and does not directly compare to the
amount of space take up by the object when saved to a file.
|
![]() | MeshCount |
RhinoObjects can have several different types of meshes and
different numbers of meshes. A b-rep can have a render and
an analysis mesh on each face. A mesh object has a single
render mesh and no analysis mesh. Curve, point, and annotation
objects have no meshes.
|
![]() ![]() | MeshObjects(IEnumerableRhinoObject, MeshingParameters, Mesh, ObjectAttributes) | Mesh Rhino Objects |
![]() ![]() | MeshObjects(IEnumerableRhinoObject, MeshingParameters, Boolean, Mesh, ObjectAttributes) | Mesh Rhino Objects |
![]() ![]() | MeshObjects(IEnumerableRhinoObject, MeshingParameters, Int32, Transform, Mesh, ObjectAttributes) | Mesh Rhino Objects |
![]() | NonConstOperation |
For derived classes implementers.
(Inherited from CommonObject.)Defines the necessary implementation to free the instance from being const. |
![]() | OnAddToDocument |
This call informs an object it is about to be added to the list of
active objects in the document.
|
![]() | OnDeleteFromDocument |
This call informs an object it is about to be deleted.
Some objects, like clipping planes, need to do a little extra cleanup
before they are deleted.
|
![]() | OnDraw |
Called when Rhino wants to draw this object
|
![]() | OnDuplicate |
Called when this a new instance of this object is created and copied from
an existing object
|
![]() | OnPick |
Called to determine if this object or some sub-portion of this object should be
picked given a pick context.
|
![]() | OnPicked |
Called when this object has been picked
|
![]() | OnSelectionChanged |
Called when the selection state of this object has changed
|
![]() | OnSpaceMorph |
Called when a space morph has been applied to the geometry.
Currently this only works for CustomMeshObject instances
|
![]() | OnSwitchToNonConst |
Is called when a non-const operation first occurs.
(Inherited from CommonObject.) |
![]() | OnTransform |
Called when a transformation has been applied to the geometry
|
![]() ![]() | Select(Boolean) | Selects an object. |
![]() | Select(Boolean, Boolean) | Selects an object. |
![]() | Select(Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Selects an object. |
![]() | SelectSubObject(ComponentIndex, Boolean, Boolean) | Reports if an object can be selected. |
![]() | SelectSubObject(ComponentIndex, Boolean, Boolean, Boolean) | Reports if an object can be selected. |
![]() | SetCustomRenderMeshParameter |
Set the named custom render mesh parameter value for this object.
|
![]() | SetTextureMapping | |
![]() | ShortDescription |
Gets a localized short descriptive name of the object.
|
![]() | SupportsRenderPrimitiveList(ViewportInfo, DisplayPipelineAttributes) |
Determines if custom render meshes will be built for a particular object.
|
![]() | SupportsRenderPrimitiveList(ViewportInfo, Boolean) | Obsolete.
Determines if custom render meshes will be built for a particular object.
|
![]() | ToString | (Inherited from Object.) |
![]() | ToString |
Returns the name of the model component type, and then its name and index.
(Inherited from ModelComponent.) |
![]() | TryGetRenderPrimitiveBoundingBox(ViewportInfo, DisplayPipelineAttributes, BoundingBox) |
Get the bounding box for the custom render meshes associated with this
object.
|
![]() | TryGetRenderPrimitiveBoundingBox(ViewportInfo, Boolean, BoundingBox) | Obsolete.
Get the bounding box for the custom render meshes associated with this
object.
|
![]() | UnhighlightAllSubObjects |
Removes highlighting from all subobjects.
|
![]() | UnselectAllSubObjects |
Removes selection from all subobjects.
|

Rhino for Mac
Supported in: 5.4Rhino for Windows
Supported in: 6.8
Reference

Rhino.DocObjectsRhinoObject
Rhino.DocObjectsAnnotationObjectBase
Rhino.DocObjectsBrepObject
Rhino.DocObjectsClippingPlaneObject
Rhino.DocObjectsCurveObject
Rhino.DocObjectsDetailViewObject
Rhino.DocObjectsExtrusionObject
Rhino.DocObjectsGripObject
Rhino.DocObjectsHatchObject
Rhino.DocObjectsInstanceObject
Rhino.DocObjectsLightObject
Rhino.DocObjectsMeshObject
Rhino.DocObjectsMorphControlObject
Rhino.DocObjectsPointCloudObject
Rhino.DocObjectsPointObject
Rhino.DocObjectsSurfaceObject
Rhino.DocObjectsTextDotObject