ObjectTable.Show Method (RhinoObject, Boolean)

ObjectTableShow Method (RhinoObject, Boolean)

If obj.IsHidden() is true, then the object will be returned to normal (visible and selectable) mode.

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public bool Show(
	RhinoObject obj,
	bool ignoreLayerMode
)
Public Function Show ( 
	obj As RhinoObject,
	ignoreLayerMode As Boolean
) As Boolean

Parameters

obj
Type: Rhino.DocObjectsRhinoObject
the normal object to show.
ignoreLayerMode
Type: SystemBoolean
if true, the object will be shown even if it is on a layer that is locked or off.

Return Value

Type: Boolean
true if the object was successfully shown.
Version Information

Rhino for Mac

Supported in: 5.4

Rhino for Windows

Supported in: 6.8
See Also