DimensionStyle Class

DimensionStyle Class

Can also be considered an annotation style since it is used for more than just dimensions
Inheritance Hierarchy
SystemObject
  Rhino.RuntimeCommonObject
    Rhino.DocObjectsDimensionStyle

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public class DimensionStyle : CommonObject
<SerializableAttribute>
Public Class DimensionStyle
	Inherits CommonObject

The DimensionStyle type exposes the following members.

Constructors
  NameDescription
Public methodDimensionStyle
Create a new non-document controlled annotation style
Protected methodDimensionStyle(SerializationInfo, StreamingContext)
Initializes a new instance of the DimensionStyle class
Top
Properties
  NameDescription
Public propertyAlternateBelowLine
Public propertyAlternateDimensionLengthDisplay
Public propertyAlternateLengthFactor
Public propertyAlternateLengthResolution
Public propertyAlternatePrefix
Public propertyAlternateRoundoff
Public propertyAlternateSuffix
Public propertyAlternateToleranceResolution
Public propertyAlternateUnitsDisplay
Public propertyAlternateZeroSuppress
Public propertyAngleFormat
Public propertyAngleResolution
Public propertyAngleZeroSuppress
Public propertyAngularRoundoff
Public propertyArcLengthSymbol
Public propertyArrowBlockId1
Public propertyArrowBlockId2
Public propertyArrowLength
Public propertyArrowType
Public propertyArrowType1
Public propertyArrowType2
Public propertyBaselineSpacing
Public propertyCentermarkSize
Public propertyCenterMarkSize
Public propertyCenterMarkType
Public propertyComponentType
Returns ModelGeometry.
(Overrides ModelComponentComponentType.)
Public propertyDimensionLengthDisplay
Public propertyDimensionLineExtension
Public propertyDimensionScale
Public propertyDimensionScaleValue
Public propertyDimRadialTextAngleType
Public propertyDimRadialTextLocation
Public propertyDimRadialTextOrientation
Public propertyDimTextAngleType
Public propertyDimTextLocation
Public propertyDimTextOrientation
Public propertyDrawForward
Public propertyDrawTextMask
Public propertyExtensionLineExtension
Public propertyExtensionLineOffset
Public propertyFixedExtensionLength
Public propertyFixedExtensionOn
Public propertyFont
Public propertyFontIndex
Public propertyHasFieldOverrides
Checks if any fields in this DimensionStyle are overrides
Public propertyId

In Rhino for Windows 6.8, this member is inherited from ModelComponentId.
Public propertyIndex

In Rhino for Windows 6.8, this member is inherited from ModelComponentIndex.
Public propertyIsChild
Tests if this DimensionStyle is a child of any other DimensionStyle
Public propertyIsDeleted
Public propertyIsReference
Public propertyIsSystemComponent
True if this model component is a system constant.

An incomplete list of system constant model components is below:

  • ON_ModelComponent::Unset

  • ON_InstanceDefinition::Empty

  • ON_Linetype::Unset
  • ON_Linetype::Continuous
  • ON_Linetype::ByLayer
  • ON_Linetype::ByParent

  • ON_Layer::Unset
  • ON_Layer::Default

  • ON_TextStyle::Unset
  • ON_TextStyle::Default
  • ON_TextStyle::ByLayer
  • ON_TextStyle::ByParent

  • ON_DimStyle::Unset
  • ON_DimStyle::Default
  • ON_DimStyle::DefaultInchDecimal
  • ON_DimStyle::DefaultInchFractional
  • ON_DimStyle::DefaultFootInchArchitecture
  • ON_DimStyle::DefaultMillimeterSmall
  • ON_DimStyle::DefaultMillimeterLarge
Public propertyLeaderArrowBlockId
Public propertyLeaderArrowLength
Public propertyLeaderArrowType
Public propertyLeaderContentAngleType
Style of leader content angle Horizontal Aligned Rotated
Public propertyLeaderCurveType
Public propertyLeaderHasLanding
Public propertyLeaderLandingLength
Public propertyLeaderTextHorizontalAlignment
Public propertyLeaderTextOrientation
Public propertyLeaderTextRotationDegrees
Public propertyLeaderTextRotationRadians
Angle of leader text for Rotated style
Public propertyLeaderTextVerticalAlignment
Public propertyLengthFactor
Public propertyLengthFormat
Public propertyLengthResolution
Linear display precision.
Public propertyMaskColor
Public propertyMaskColorSource
Public propertyMaskOffset
Public propertyCode exampleName

In Rhino for Windows 6.8, this member is inherited from ModelComponentName.
Public propertyParentId
Get or Set the Id of this DimensionStyle's parent. If ParentId is Guid.Empty, this DimensionStyle has no parent
Public propertyPrefix
Public propertyRoundoff
Public propertyScaleLeftLengthMillimeters
Public propertyScaleRightLengthMillimeters
Public propertyStackFractionFormat
Public propertyStackHeightScale
Public propertySuffix
Public propertySuppressArrow1
Public propertySuppressArrow2
Public propertySuppressExtension1
Public propertySuppressExtension2
Public propertyTextAlignment
Public propertyTextGap
Public propertyTextHeight
Public propertyTextHorizontalAlignment
Public propertyTextMoveLeader
Public propertyTextOrientation
Public propertyTextRotation
Public propertyTextUnderlined
Public propertyTextVerticalAlignment
Public propertyToleranceFormat
Public propertyToleranceHeightScale
Public propertyToleranceLowerValue
Public propertyToleranceResolution
Public propertyToleranceUpperValue
Public propertyToleranceZeroSuppress
Public propertyZeroSuppress
Top
Methods
  NameDescription
Public methodAlternateDimensionLengthDisplayUnit
Public methodClearAllFieldOverrides
Sets all the fields in this DimensionStyle to be not overridden Does not change any dimstyle_id's or parent_id's
Public methodClearFieldOverride
Set the field as not overridden
Public methodCommitChanges
Public methodCopyFrom
Copy settings from source dimension style without changing the name, Id or index of this DimensionStyle.
Public methodCreatePreviewBitmap
Public methodDimensionLengthDisplayUnit
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.
Public methodDuplicate
Construct a deep (full) copy of this object.
Public methodDuplicate(String, Guid, Guid)
Construct a deep (full) copy of this object.
Public methodIsChildOf
Tests if this DimensionStyle is a child of a specific DimensionStyle
Public methodIsFieldOverriden
Public methodScaleLengthValues
Scales all length values by 'scale'
Public methodSetFieldOverride
Set a field as overridden
Top
Version Information

Rhino for Mac

Supported in: 5.4

Rhino for Windows

Supported in: 6.8
See Also