NamedConstructionPlaneTable Class

NamedConstructionPlaneTable Class

Contains all named construction planes in a rhino document.

This class cannot be inherited.

Inheritance Hierarchy
SystemObject
  Rhino.DocObjects.TablesNamedConstructionPlaneTable

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class NamedConstructionPlaneTable : IEnumerable<ConstructionPlane>, 
	IEnumerable
Public NotInheritable Class NamedConstructionPlaneTable
	Implements IEnumerable(Of ConstructionPlane), IEnumerable

The NamedConstructionPlaneTable type exposes the following members.

Properties
  NameDescription
Public propertyCount
Number of construction planes in the table.
Public propertyDocument
Gets the document that owns this table.
Public propertyItem
Conceptually, the named construction plane table is an array of ConstructionPlanes and their associated names. The operator[] can be used to get individual ConstructionPlanes.
Top
Methods
  NameDescription
Public methodAdd
Adds named construction plane to document.
Public methodDelete(Int32)
Remove named construction plane from the document.
Public methodDelete(String)
Remove named construction plane from the document.
Public methodFind
Finds a named construction plane.
Public methodGetEnumerator
Top
Version Information

Rhino for Mac

Supported in: 5.4

Rhino for Windows

Supported in: 6.8
See Also