HiddenLineDrawingParameters Class

HiddenLineDrawingParameters Class

Input used for computing a hidden line drawing
Inheritance Hierarchy
SystemObject
  Rhino.GeometryHiddenLineDrawingParameters

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class HiddenLineDrawingParameters
Public Class HiddenLineDrawingParameters

The HiddenLineDrawingParameters type exposes the following members.

Constructors
  NameDescription
Public methodHiddenLineDrawingParameters
default constructor
Top
Properties
  NameDescription
Public propertyAbsoluteTolerance
Absolute tolerance is used to decide if curves overlap or intersect. A suggested value is to use RhinoDoc.AbsoluteTolerance
Public propertyFlatten
Flatten the computed geometry
Public propertyIncludeHiddenCurves
Include hidden curves in hidden line drawing (default is true)
Public propertyIncludeTangentEdges
Include tangent edges in hidden line drawing (default is true)
Public propertyIncludeTangentSeams
Include tangent seams in hidden line drawing (default is true)
Top
Methods
  NameDescription
Public methodAddClippingPlane
Specify clipping planes that are active for this view.
Public methodAddGeometry(GeometryBase, Object)
Add geometry that should be included in the calculation
Public methodAddGeometry(GeometryBase, Transform, Object)
Add geometry that should be included in the calculation
Public methodSetViewport(RhinoViewport)
Set the viewport for the hidden line drawing (HLD). The viewport supplies the projection that determinest he visibility of curves, and the HLD coordinate system in which the resulting curves are represented. The HLD-coordinate system is a right handed system for 3-D model space, in which the 3rd coordinate direction is the projection direction. In particular the z-coordinate direction points from the scene toward the camera.
Public methodSetViewport(ViewportInfo)
Set the viewport for the hidden line drawing (HLD). The viewport supplies the projection that determines the visibility of curves, and the HLD coordinate system in which the resulting curves are represented. The HLD-coordinate system is a right handed system for 3-D model space, in which the 3rd coordinate direction is the projection direction. In particular the z-coordinate direction points from the scene toward the camera.
Top
Version Information

Rhino for Windows

Supported in: 6.8
See Also