HiddenLineDrawingParameters.AddGeometry Method (GeometryBase, Transform, Object)

HiddenLineDrawingParametersAddGeometry Method (GeometryBase, Transform, Object)

Add geometry that should be included in the calculation

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public bool AddGeometry(
	GeometryBase geometry,
	Transform xform,
	Object tag
)
Public Function AddGeometry ( 
	geometry As GeometryBase,
	xform As Transform,
	tag As Object
) As Boolean

Parameters

geometry
Type: Rhino.GeometryGeometryBase
Currently only curves, meshes, breps, surfaces, and extrusions are supported
xform
Type: Rhino.GeometryTransform

[Missing <param name="xform"/> documentation for "M:Rhino.Geometry.HiddenLineDrawingParameters.AddGeometry(Rhino.Geometry.GeometryBase,Rhino.Geometry.Transform,System.Object)"]

tag
Type: SystemObject
arbitrary data to be associated with this geometry

Return Value

Type: Boolean
true if the type of geometry can be added for calculations. Currently only curves, meshes, breps, surfaces and extrusions are supported
Version Information

Rhino for Windows

Supported in: 6.8
See Also